Please sign in to your GRAPHISOFT ID

Fields are required.

Email
Password

Forgot password?

ArchiCAD File converters

From this page you can download old ArchiCAD packages which are pre-installed and updated to the latest available build. You can use these packages to convert your old ArchiCAD files to a format which is supported by current ArchiCAD versions.

Frequently Asked Questions

How do I install these packages?

You don't - and that is exactly the point. These are ready-to use packages. Just download and unpack them, then drop them in a folder inside your Program Files or Applications folder.


Will ArchiCAD File Converter run on Windows 7 and newer?

Yes. You can run it in "native" Windows 7 mode, we do not actually recommend running it in emulated "XP mode". The same applies for Windows 8 and 8.1. You might get an error message concerning missing MSVCsomething.DLL files. If you encounter this please download the missing DLLs from here.


Will ArchiCAD Converter Packages run on upcoming operating systems?

GRAPHISOFT cannot guarantee that older ArchiCAD version or File Converter packages will run on upcoming operating systems. Before updating your operating system, please do consider the migration of your older files.


Will ArchiCAD 7.0 and ArchiCAD 9 File Converter run on Mac OS X 10.7 and newer?

No. Since the Rosetta environment is discontinued in 10.7. We advise to keep an old machine with Mac OS X Snow Leopard, or prepare a dual boot machine with 10.6 and 10.7.


Will ArchiCAD 7.0 File Converter run on Intel Macs with Mac OS X Snow Leopard?

Yes. Mac OS X on intel machines have a built-in environment (Rosetta) to run PPC applications. (This is an optional install from the System install disk). You can not install ArchiCAD 7.0, but this package is pre-installed, so you just need to drag-and-drop it into your Applications folder. 


What version of WIBU protection key do I need to run these packages?

The file converter packages run with either the green WibuKey or the metal CodeMeter keys.  


How do I open really old files if I have a CodeMeter key?

Download the ArchiCAD 7.0 File Converter package. With this, you can open files as old as 4.1. Then, once converted to ArchiCAD 7.0 format, you can open the file in ArchiCAD 10. To run ArchiCAD 10 with a CodeMeter key, you need to install the CodeMeter Enabler, or you can just download the ArchiCAD 10 File Converter package from this page. You must also have the WIBU driver installed.


Which ArchiCAD version supports which ArchiCAD files?

ArchiCAD 17 can open files from 8.1 and above. For other versions, check out our ArchiCAD version compatibility table: Help Center


How do I update library parts?

Library parts are backward compatible without limitation, however we do recommend to update libraries older than 7.0 (including 7.0), because those old objects do not have a GUID which current ArchiCAD versions use to identify objects. To learn more about this, read: Help Center


Downloads

ArchiCAD 10 Packages - open files from version 6.5

Note for Mac OS X Users:

Download Language Windows Mac OSX Last modified
ArchiCAD 10 Package*
INT

173 MB

206 MB
Nov 13, 2013
ArchiCAD 10 Package**
USA

155 MB

189 MB
Nov 13, 2013

ArchiCAD 9 Packages - open files from version 5.0

Note for Mac OS X Users:

Download Language Windows Mac OSX Last modified
ArchiCAD 9 Package*
INT

282 MB

307 MB
Sept 3, 2012
ArchiCAD 9 Package**
USA

265 MB

284 MB
Sept 3, 2012

ArchiCAD 7.0 Packages - open files from version 4.1

Note for Mac OS X Users:

Download Language Windows Mac OSX Last modified
ArchiCAD 7.0 Package*
INT

119 MB

132 MB
Febr 23, 2008
ArchiCAD 7.0 Package**
USA

154 MB

163 MB
Febr 23, 2008

* Use for any localized version which use the Western European font encoding, and where ground floor is numbered '0'

** Use for any localized version where ground floor is numbered '1'